This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] how to make Domain0 support acpi?

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] how to make Domain0 support acpi?
From: wangbbb@xxxxxxxxxx
Date: Thu, 18 May 2006 16:24:14 +0800
Delivery-date: Thu, 18 May 2006 01:25:22 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
As I know, linux kernel has support acpi greatly, but xen-linux(Domain0)
cannot support even basic acpi function, such as close the power source
then shutdown Domain0.

When I tried to suspend my xen-linux, the screen become black and then
immediately return running mode. The suspend operation is failed.

I have tried to include the CONFIG_SOFTWARE_SUSPEND options when compiling
kernels, no effect come out.

Who can tell me how to make Domain0 support acpi? maybe a list of
modifications need to do.

Best wishes!


Bibo Wang

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-devel] how to make Domain0 support acpi?, wangbbb <=