This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Minix as an HVM guest crashes

To: "Petersson, Mats" <Mats.Petersson@xxxxxxx>
Subject: Re: [Xen-devel] Minix as an HVM guest crashes
From: "Jonathan M. McCune" <jonmccune@xxxxxxx>
Date: Tue, 16 May 2006 17:29:27 -0400
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Tue, 16 May 2006 14:29:50 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <907625E08839C4409CE5768403633E0BA7FC7D@xxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <907625E08839C4409CE5768403633E0BA7FC7D@xxxxxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Debian Thunderbird 1.0.7 (X11/20051017)
During boot, Minix prints "Executing in 32-bit protected mode."


Petersson, Mats wrote:

Is Minix a 16-bit or 32-bit OS? If it's 16-bit, it's most likely the
cause of problems. There are a lot of places in Xen where it's assumed
that the base of a segment is zero unless in real-mode... Just a thought...

-----Original Message-----
From: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx [mailto:xen-devel-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Petersson, Mats
Sent: 16 May 2006 21:35
To: Jonathan M. McCune; xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: RE: [Xen-devel] Minix as an HVM guest crashes

-----Original Message-----
From: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
[mailto:xen-devel-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of
M. McCune
Sent: 16 May 2006 21:09
To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] Minix as an HVM guest crashes

Hello Xen community,

I have tried to boot Minix 3.1.2 as an HVM guest on Xen 3.0.2 on a system with AMD SVM extensions, but it crashes. I have
booted Linux and Windows XP as HVM guests on this system. I have included here the output of `xm dmesg` after attempting to boot the Minix domain. Here is my minix.xm file:

kernel = "/usr/lib/xen/boot/hvmloader"
memory = 512
name = "Minix"
disk = [ 'file:/minix/disk.img,ioemu:hda,w' ] vif = [ 'type=ioemu, bridge=xenbr0' ] device_model = '/usr/lib/xen/bin/qemu-dm'
memmap = '/usr/lib/xen/boot/mem-map.sxp'

The command I executed in dom0 to boot the minix.xm domain was `xm create -f minix.xm`. The HVM guest window opens, and minix boots to the point where it asks whether I want to configure for "Large" or "Small" memory. Regardless of my choice, the HVM guest window "blinks out of existence" shortly thereafter, and automatically restarts itself once, before crashing again in exactly the same way. I chose Large both times. This auto-restart behavior is why there are two guests in the `xm dmesg` output below:

Does anybody know why it crashes? Is this a Minix bug? Xen bug? Admittedly, I haven't tried the latest xen-unstable yet, so perhaps the issue is already solved.


This is a typical dump of a unimplemented opcode in hvm/platform.c.
I'm not quite sure which opcode it's trying to execute, but I'm sure
this is why it's failing. I'm also confused as to the base address of
the instruction, because the 31A7 instruction is a "add $10, %esp",
which shouldn't be page-faulting. One possibility is that the base of
the CS register isn't zero, in which case the dump of the instruction
bytes is bogus...
I doubt that the Latest Xen will fix anything.


Xen-devel mailing list

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>