This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Re: [RFC PATCH 23/35] Increase x86 interrupt vector range

To: Keir Fraser <Keir.Fraser@xxxxxxxxxxxx>
Subject: [Xen-devel] Re: [RFC PATCH 23/35] Increase x86 interrupt vector range
From: Ingo Oeser <ioe-lkml@xxxxxxxxxx>
Date: Sun, 14 May 2006 19:08:02 +0200
Cc: Xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxx>, Chuck Ebbert <76306.1226@xxxxxxxxxxxxxx>, virtualization <virtualization@xxxxxxxxxxxxxx>, linux-kernel <linux-kernel@xxxxxxxxxxxxxxx>, Chris Wright <chrisw@xxxxxxxxxxxx>, Ian Pratt <Ian.Pratt@xxxxxxxxxxxxx>
Delivery-date: Mon, 15 May 2006 00:38:49 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <96b6a9b036fc030017549f3446a13aab@xxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <200605131346_MC3-1-BFAF-FA0A@xxxxxxxxxxxxxx> <96b6a9b036fc030017549f3446a13aab@xxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: KMail/1.9.1
On Sunday, 14. May 2006 09:52, Keir Fraser wrote:
> If we really want it disambiguated then we should call it something 
> like 'bitwise-negated' or 'ones-complemented'. 'Complemented' alone is 
> worse than 'negated' imo, since negation is at least the usual name for 
> the tilde operator in C while complementation is an ambiguous term 
> unless you know the base/radix.

Not really. 

I've seen "negate" only be used to mean "twos complement"
and "invert" only be seen with "ones complement".

So if you like to be clear, just use "negate" vs. "invert".


Ingo Oeser

Xen-devel mailing list