This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] No VMX-guests on Intel Xeon/VT

Hi all,

first thanks a lot for everybody who is reading my posts and thanks a lot for the people who try to help me with my problem.

I know it's hard to work on beta-hardware with beta-technology, with a beta-OS, beta-drivers and a software that just is a x.0.0-release - but I never give up :-))))

>Start the domain with vnc=1 and vncviewer=0. Then execute "vncviewer
>ipaddress:dom_id" or "vncviewer localhost:dom_id" to connect to the
I tried this already before, but I only get "connection refused".

OK, where I am right now:

SuSE Linux 10.1 Beta2 x86-64 with Gnome as desktop on a Dual-Xeon 3,2GHz with dualcore/HT/VT, 4GB RAM with Kernel 2.6.16_rc1_git3-4.

I installed SuSE Linux completely new, I updated XEN to 3.0.1 and my Linux-guests are still working.

But I even don't get running a very simple freedos as vmx-xenU, with
'qemu -hda /data/xen/images/freedos/freedos.dsk -boot c' it is running with Qemu :-((((

I tried all the following on an identical machine with the same results, I also tried it SuSE Linux 10.1 Beta2 i386 without success.

Now I will have a look at SuSE Linux 10.0, but with this the onboard-NICs are not working, so I have to plug in PCI-card.
BTW: SuSE Linux or SLES is a must!

I always use the "xmexample.vmx" as base for my vmx-xenU-guests, there I only adjust the following:

memory = 128
name = "freedos.vmx"
vif = [ 'type=ioemu, bridge=xenbr0' ] # (some times to give a MAC-adr)
disk = [ 'file:/data/xen/images/freedos/freedos.dsk,ioemu:hda,w' ]

Now I start the guest with:

# xm create freedos.vmx

And I get:

  Using config file "freedos.vmx".
  VNC= 1
  vncviewer -listen: Listening on port 11001 (flash port 10901)
vncviewer -listen: Command line errors are not reported until a connection comes in.
  Started domain freedos.vmx

But no VNC-viewer is started!

Trying to connect the server from OS/2, Linux (I also tried it from the XEN 3.0 Live CD) and even Windows results in a 'connection refused' using <xen0-host-ip>:<vm-id> ( or :<5500+vmid> ( and in an error 'ReadFromRFBServer: rd::EndOfStrem' if I connect at and on the xen0-host I get also an error:

  vncviewer -listen: invalid command line argument: -log
  TightVNC viewer version 1.2.9

  Usage: vncviewer [<OPTIONS>] [<HOST>][:<DISPLAY#>]

'xm list' and 'xm top' telling me the following:

# xm list
  Name                              ID Mem(MiB) VCPUs State  Time(s)
  Domain-0                           0     3873     4 r-----   171.7
  freedos.vmx                        1      128     1 -b----     0.0

# xm top
xentop - 19:54:59   Xen 3.0.1
2 domains: 1 running, 1 blocked, 0 paused, 0 crashed, 0 dying, 0 shutdown
Mem: 4186112k total, 4181288k used, 4824k free    CPUs: 4 @ 3192MHz

NAME STATE CPU(sec) CPU(%) MEM(k) MEM(%) MAXMEM(k) MAXMEM(%) VCPUS NETS NETTX(k) NETRX(k) SSID Domain-0 -----r 172 0.0 3965268 94.7 no limit n/a 4 8 8712 158371 0 freedos.vmx --b--- 0 0.0 131356 3.1 131356 3.11 0 0 0 0

No I shutdown the xenU.

As suggested I change in the config:


and start freedos again, 'netstat -nat' doesn't tell me anything new, but anyway I try it, this time with vmid 2 but with the same result as before :-(

Next try is changing the config again:


Now finaly I get a local window open, it shows some BIOS-info, s.th. about booting from harddisk and finally the boot-menu, if I press 1 or 2 the boot-menu disappears and I get only a cursor in the left upper corner (F8) lets me say twice 'Y' the it also stops, and on pressing 3 I get a black, then a blank screen and the window closes :-(

But the xenU-domain is still running:

  Name                              ID Mem(MiB) VCPUs State  Time(s)
  Domain-0                           0     3873     4 r-----   499.3
  freedos.vmx                        7      128     1 -b----     1.2

So I shut it down.

I also created images with VirtualPC/2 (Warp Server and WinXP) and copied them with dd into an image-file, I can start both images with Qemu, well both aren't working really because they are trapping in Qemu, but actually they should do something if started as vmx-domU - but there is no activity at all, no window opens (sdl=1), 'xm list' and 'xm top' say that the OS is running (with status 'b') but CPU is at 0 all the time - configurations are the same than the ones for freedos (exept for memory=512)!

Today I also tried the XEN 3.0-Demo-CD on the machine and it's running.

Does this version also supports Intel/VT as VMX-guests? I could not find the vmxloader in the fs, so probably it isn't integrated?

Thanks very much for your help,

Chau y hasta luego,


Xen-users mailing list