WARNING - OLD ARCHIVES

This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
   
 
 
Xen 
 
Home Products Support Community News
 
   
 

xen-devel

Re: [Xen-devel] USB virt 2.6 split driver patch series

To: NAHieu <nahieu@xxxxxxxxx>
Subject: Re: [Xen-devel] USB virt 2.6 split driver patch series
From: harry <harry@xxxxxxxxxxxxxxxxxxxxxxxxxxxxx>
Date: Tue, 22 Nov 2005 10:24:29 +0000
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Tue, 22 Nov 2005 10:24:59 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <5d7aca950511211800j9799a2dy3186ef4133213417@xxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <1132579104.31295.110.camel@xxxxxxxxxxxxxxxxxxxxx> <20051121134940.GA25045@xxxxxxxxx> <1132581661.31295.134.camel@xxxxxxxxxxxxxxxxxxxxx> <5d7aca950511210641n23d79fduc2e462c3dcd07810@xxxxxxxxxxxxxx> <1132586050.31295.145.camel@xxxxxxxxxxxxxxxxxxxxx> <5d7aca950511210727i741148efl71f025577680d994@xxxxxxxxxxxxxx> <1132587554.31295.154.camel@xxxxxxxxxxxxxxxxxxxxx> <5d7aca950511210902j5002bbfdxe52b1a32517d6c8b@xxxxxxxxxxxxxx> <1132593451.31295.171.camel@xxxxxxxxxxxxxxxxxxxxx> <5d7aca950511211759i63ed353al8f95ea411bbd49ff@xxxxxxxxxxxxxx> <5d7aca950511211800j9799a2dy3186ef4133213417@xxxxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
On Tue, 2005-11-22 at 11:00 +0900, NAHieu wrote:
> On 11/22/05, NAHieu <nahieu@xxxxxxxxx> wrote:
> > I had a look at xenidc code, and found some code like this:
> >
> > --
> > static void xenidc_endpoint_destroy_1(xenidc_callback * callback)
> > {
> >         trace();
> >
> >         {
> >                 xenidc_endpoint_callback *endpoint_callback =
> >                     container_of(callback, xenidc_endpoint_callback, 
> > callback);
> >
> >                 endpoint_callback->destroyed = 1;
> >
> >                 xenidc_work_wake_up();
> >         }
> > }
> > --
> >
> > Why name it *destroy_1? it is a common practice to name a local
> > function with _ or __ as prefix. So for example
> > xenidc_endpoint_destroy_1() should be named
> > _xenidc_endpoint_destroy_1() or __xenidc_endpoint_destroy_1()
> >
> 
> Oops, typo. I meant _xenidc_endpoint_destroy_1() should be named
> _xenidc_endpoint_destroy() or __xenidc_endpoint_destroy()
> 

This is for chains of functions which are logically part of the same
operation but are split by asynchronous callbacks. The first function is
called something: xenidc_endpoint_destroy() for example the next
xenidc_endpoint_destroy_1, the next xenidc_endpoint_destroy_2 and so on.
Leading underscores won't work past _1.  Unless you want _ then __ then
___ :-)  Also identifiers with two leading underscores are reserved by
ANSI C for the C compiler implementation so I think it's not a good idea
to use them.

Thanks

Harry.


_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxxxxxxxx
http://lists.xensource.com/xen-devel

<Prev in Thread] Current Thread [Next in Thread>