This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Re: Unable to find root device. domU??

David Becker wrote:

" >There are some fixes for domU device probing waiting in the queue to " >get pushed to the public tree. Hopefully should fix some of these " >failures.

I tried today's pull and xenU will still not detect the vbd.
This is not consistent across hardware.   xenU detects the vbd OK on
a Dell PE1650 but not on an IBM HS20 Blade (type 8678).
The Dell has a scsi drive and the IBM has IDE. Both hosts have LVM partitions for the xenUs.

xenU on the IBM says:
Xen virtual console successfully installed as tty1 Event-channel device installed. xen_blk: Initialising virtual block device driver xen_net: Initialising virtual ethernet driver.

This is exactly the problem I was seeing all last week. I re-imaged my base system to clean up the filesystem, and that appears to have solved the problem on two different machines. So it seems that the bug is also exposed or affected by something in the filesystem, possibly an out of date library, or something. The only clue I can offer (which may just be coincidence) is that all the affected systems had previously run xen 2.0 in the past, while the new (working) system was a clone of a system that had only ever had xen 3.0 on it.

Rob Gardner

Xen-devel mailing list