This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] domU kernel panic with root fs

To: xen-devel@xxxxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] domU kernel panic with root fs
From: Bjoern Sessler <bjoern.sessler@xxxxxx>
Date: Sat, 13 Nov 2004 12:31:31 +0100
Delivery-date: Sat, 13 Nov 2004 11:52:50 +0000
Envelope-to: steven.hand@xxxxxxxxxxxx
List-archive: <http://sourceforge.net/mailarchive/forum.php?forum=xen-devel>
List-help: <mailto:xen-devel-request@lists.sourceforge.net?subject=help>
List-id: List for Xen developers <xen-devel.lists.sourceforge.net>
List-post: <mailto:xen-devel@lists.sourceforge.net>
List-subscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=subscribe>
List-unsubscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=unsubscribe>
Reply-to: bjoern.sessler@xxxxxx
Sender: xen-devel-admin@xxxxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.4b) Gecko/20030507

i installed xen 2.0 on my new installed gentoo box. xen0 works great, but i can't get domU kernel to mount root fs:

VFS: Cannot open root device "sda5" or unknown-block(8,5)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,5)

this happens with all root-fs i've tried, ttylinux and my cloned root from Xen0. ttylinux lives now on a hdc partition, the cloned root were lvm2 devices over kernlraid, which worked fine on my old gentoo with xeno-unstable.

fstab on ttylinux also points to sda5, sda5 also exists on Xen0, but also hda1 doesn't work. i also saw similar problem with wrong config of disk= parameter, but doesn't help me.

config looks like following for these parts:

# disk = [ 'phy:vg1/vm101,hda1,w', 'phy:vg1/vm101-swap,hda2,w', 'phy:sdb7,hdc1,r!', 'phy:sdc5,hdc2,r!' ]
disk = [ "file:/machines/backup/ttylinux-xen,sda5,w" ]
#disk = [ 'phy:hdc6,hda1,w' ]

#ip = ""
#netmask = ""
#gateway = ""

# Set root device.
root = "/dev/sda5 ro"

i believe i forgot something in the kernel for XenU but i started with default-config.

Thanks & Regards,

This SF.Net email is sponsored by: InterSystems CACHE
FREE OODBMS DOWNLOAD - A multidimensional database that combines
robust object and relational technologies, making it a perfect match
for Java, C++,COM, XML, ODBC and JDBC. www.intersystems.com/match8
Xen-devel mailing list