This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Re: VIF Interfaces not transparent to all ethernet protocols

To: xen-devel@xxxxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] Re: VIF Interfaces not transparent to all ethernet protocols?
From: Armin Kemper <Armin.Kemper@xxxxxxx>
Date: Tue, 9 Nov 2004 19:44:52 +0000 (UTC)
Delivery-date: Wed, 10 Nov 2004 12:45:57 +0000
Envelope-to: steven.hand@xxxxxxxxxxxx
List-archive: <http://sourceforge.net/mailarchive/forum.php?forum=xen-devel>
List-help: <mailto:xen-devel-request@lists.sourceforge.net?subject=help>
List-id: List for Xen developers <xen-devel.lists.sourceforge.net>
List-post: <mailto:xen-devel@lists.sourceforge.net>
List-subscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=subscribe>
List-unsubscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=unsubscribe>
References: <loom.20041108T212559-866@xxxxxxxxxxxxxx> <200411091346.24939.mark.williamson@xxxxxxxxxxxx>
Sender: xen-devel-admin@xxxxxxxxxxxxxxxxxxxxx
User-agent: Loom/3.14 (http://gmane.org/)
> If not, you might want to a) try starting Xend without any preconfigured 
> bridges to see if that works and then b) adapt the scripts to suit your setup 
> properly.

I tried both of that, without any success.

My first attempt was adjusting the xend bridging script to create 2 bridges,
one for each physical interface on the host.

Then I tried the VIF <-> eth (vm) transfer without any bridging setup,
so that the VIF Interface did not have any routes/ips or bridges attached.
Same behaviour.

PPPoE Packets from Domain1 eth1   to Domain0 vif1.1    never arrive,
PPPoE Packets from Domain0 vif1.1 to Domain1 eth1      work fine.

Maybe I'll give the pppoed instead of rp-pppoe a try.
But the above has been tested with rp-pppoed on both sides.

So I cannot really understand whats going on, as I see it vif-Interfaces and 
the corresponding ethx-Interfaces in the vm should be like an ethernet "tunnel",
everything send to the ethx inside the vm should appear on the vif interface and
vice versa.

Is there any possibility to trace the network front- or backend drivers?
Some kind of tcpdump in "between"? 

 -- Armin

This SF.Net email is sponsored by:
Sybase ASE Linux Express Edition - download now for FREE
LinuxWorld Reader's Choice Award Winner for best database on Linux.
Xen-devel mailing list