This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] xm save error

To: Xen <xen-devel@xxxxxxxxxxxxxxxxxxxxx>
Subject: Re: [Xen-devel] xm save error
From: Marconi Rivello <marconirivello@xxxxxxxxx>
Date: Thu, 4 Nov 2004 16:56:57 -0200
Delivery-date: Thu, 04 Nov 2004 19:06:06 +0000
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:reply-to:to:subject:in-reply-to:mime-version:content-type:content-transfer-encoding:references; b=sQZ/dxa2UA5Btpj8TRQCD+l1qLmOifZIXdMXn69qEFyoTyjBqGR4NzbkVmEBQrqgP7D+SF2MGooHaLcYK8YcPy+JLj03GAdcq8IBTnOJOc+7Qzrd22RQvw7WixSQysK8/88Fz9Ewy+8N/0PBesFmpbPqAvYtFUTvmoJksZYNhho=
Envelope-to: steven.hand@xxxxxxxxxxxx
In-reply-to: <E1CNGa3-00071C-00@xxxxxxxxxxxxxxxxx>
List-archive: <http://sourceforge.net/mailarchive/forum.php?forum=xen-devel>
List-help: <mailto:xen-devel-request@lists.sourceforge.net?subject=help>
List-id: List for Xen developers <xen-devel.lists.sourceforge.net>
List-post: <mailto:xen-devel@lists.sourceforge.net>
List-subscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=subscribe>
List-unsubscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=unsubscribe>
References: <bd15b9d5041028114929b18e2@xxxxxxxxxxxxxx> <E1CNGa3-00071C-00@xxxxxxxxxxxxxxxxx>
Reply-to: Marconi Rivello <marconirivello@xxxxxxxxx>
Sender: xen-devel-admin@xxxxxxxxxxxxxxxxxxxxx
On Thu, 28 Oct 2004 21:09:06 +0100, Ian Pratt <ian.pratt@xxxxxxxxxxxx> wrote:
> Odd. 'save' is a very simple special case of 'migrate'. Migrate
> has been tested loads recently, but I guess that 'save'
> hasn't. It's so simple, how could it break? ;-)
> Does 'ps auxw' show an 'xfrd' running?
> Does 'xend restart' help?
> What happens if you do an 'xm migrate VMID localhost' ?
> Ian


Thanks for the fast reply, and sorry about my delay.

xfrd wasn't running. I tried to start it, but there are some libs
missing. I am running a slackware 10 install.

# ldd xfrd
        libxc.so.1.3 => /usr/lib/libxc.so.1.3 (0x4002c000)
        libxutil.so.1.3 => /usr/lib/libxutil.so.1.3 (0x40039000)
        libz.so.1 => /usr/lib/libz.so.1 (0x4003c000)
        libcurl.so.2 => /usr/lib/libcurl.so.2 (0x4004d000)
        libssl.so.4 => not found
        libcrypto.so.4 => not found
        libgssapi_krb5.so.2 => not found
        libkrb5.so.3 => not found
        libk5crypto.so.3 => not found
        libcom_err.so.3 => not found
        libresolv.so.2 => /lib/libresolv.so.2 (0x40078000)
        libdl.so.2 => /lib/libdl.so.2 (0x4008a000)
        libc.so.6 => /lib/libc.so.6 (0x4008d000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
        libssl.so.0 => not found
        libcrypto.so.0 => not found

Looks like slackware 10 doesn't come with kerberos5. So I downloaded
it, and the latest openssl. I had to create some links manually:

libcom_err.so.3 -> libcom_err.so
libcrypto.so.0 -> libcrypto.so.4
libcrypto.so.4 -> libcrypt.so
libssl.so.0 -> libssl3.so
libssl.so.4 -> libssl3.so

After that, the xfrd started along with xend. And the xm save VMID
FILE worked. But when I tried the xm restore FILE, Xen created a new
VM, but didn't load the memory back (I know because of no HD activity
after the command), and didn't return from the xm restore command.
Logging into another console, and issuing xm list:

Name              Id  Mem(MB)  CPU  State  Time(s)  Console
Domain-0           0      123    0  r----    219.0
Domain-8           8       64    0  --p--      0.0

The Domain-8 name shows that Xen didn't restore the previous VM's info
(the name was something else).

Any ideas? (besides changing the distro)


This SF.Net email is sponsored by:
Sybase ASE Linux Express Edition - download now for FREE
LinuxWorld Reader's Choice Award Winner for best database on Linux.
Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • Re: [Xen-devel] xm save error, Marconi Rivello <=