This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Java vs Xen 2.0.1

Greetings all, have a probably stupid question but have been lurking for
awhile and thought I would ask...

Does anyone have any specific experience with running java stuff within
Xen? I didn't appear to have any major issues (had some minor ones) with
2.0 but for some reason 2.0.1 just doesn't work right.

Depending on the JDK/JRE mix it does different things. Sometimes it just
completely freezes the xen instance (domain 0 continues without issues
mind you). Other times it will page fault (and reboot the xen instance).

This is running suse 9.1. I have tried fedora core 1 as well with
similar problems (am going to try core 2 if I get the chance). 

Java versions tried:
Sun 1.4.2_03
IBM 1.3.1

I tried with both the stock (binary) version of Xen and compiled from
source (no compile errors). Similar issues with both.

Other than this xen is happy, as long as I don't try to do stuff with
java it boogies along all happy.

Also keep in mind that I am _not_ a programmer, so questions about
how/why/what about java aren't going to be answered LOL. I am a sysadmin
that is playing around with running some java tools we use within Xen.

I just wanted to see if anyone else had run into issues before I dive
into trace file hell!

Thanks for any help!


Dave C. Boyle <dboyle@xxxxxxxxxxxxxx>

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now. 
Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>