This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] dom0 won't boot

To: Barry Rountree <rountree@xxxxxxxxxx>, <xen-devel@xxxxxxxxxxxxxxxxxxxxx>
Subject: RE: [Xen-devel] dom0 won't boot
From: James Harper <JamesH@xxxxxxxxxxxxxxxx>
Date: Fri, 30 Jul 2004 10:25:12 +1000
Delivery-date: Fri, 30 Jul 2004 01:30:28 +0100
Envelope-to: steven.hand@xxxxxxxxxxxx
In-reply-to: <200407292016.50271.rountree@xxxxxxxxxx>
List-archive: <http://sourceforge.net/mailarchive/forum.php?forum=xen-devel>
List-help: <mailto:xen-devel-request@lists.sourceforge.net?subject=help>
List-id: List for Xen developers <xen-devel.lists.sourceforge.net>
List-post: <mailto:xen-devel@lists.sourceforge.net>
List-subscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=subscribe>
List-unsubscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=unsubscribe>
References: <E1BqJ6G-00048m-00@xxxxxxxxxxxxxxxxx> <200407291830.37697.rountree@xxxxxxxxxx>, <200407292016.50271.rountree@xxxxxxxxxx>
Sender: xen-devel-admin@xxxxxxxxxxxxxxxxxxxxx
Thread-index: AcR1y63WlFpE4Ta4SrGXSO33vT/R5Q==
Thread-topic: [Xen-devel] dom0 won't boot
My machine rebooted under similar circumstances, although I might have got something from dom0, but I put noacpi in the xen boot line in grub and it fixed it right up.

From: Barry Rountree
Sent: Fri 30/07/2004 10:16 AM
To: xen-devel@xxxxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] dom0 won't boot

On Thursday 29 July 2004 06:30 pm, Barry Rountree wrote:

> > Add "console=ttyS0" to the
> > linux command line:
> Ok, let me get this set up and I'll post what happens.

Here's the output from the serial console:

Restarting system.
[rebooting from linux-smp into xen]
kernel (hd0,4)/boot/xen.gz dom0_mem=131072 com1=115200 noht noreboot
   [Multiboot-elf, <0x100000:0x40c4c:0x344f4>, shtab=0x176078, entry=0x100000]
module (hd0,4)/boot/vmlinuz-2.4.26-xen0 root=/dev/sda5 ro console=ttyS0
   [Multiboot-module @ 0x177000, 0x30b8fc bytes]

That's it.

To sum up, things that have changed from the last time this worked:

(Slightly) newer code.
Using XFS instead of ext2.
Only two partitions (1GB swap and 15GB) instead of several smaller ones.
I was in a bit more of a hurry...

Let me know if there's anything else useful I can try.  Otherwise, I'll wipe 
the drive and start over in the morning.


This SF.Net email is sponsored by OSTG. Have you noticed the changes on
Linux.com, ITManagersJournal and NewsForge in the past few weeks? Now,
one more big change to announce. We are now OSTG- Open Source Technology
Group. Come see the changes on the new OSTG site. www.ostg.com
Xen-devel mailing list