This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Newbie question: Error creating domain

To: Ian Pratt <Ian.Pratt@xxxxxxxxxxxx>
Subject: Re: [Xen-devel] Newbie question: Error creating domain
From: Fredrik Dahlberg <fdaa@xxxxxxxxxx>
Date: Mon, 19 Jul 2004 00:47:57 +0200
Cc: xen-devel@xxxxxxxxxxxxxxxxxxxxx
Delivery-date: Sun, 18 Jul 2004 23:50:00 +0100
Envelope-to: steven.hand@xxxxxxxxxxxx
In-reply-to: <E1BmFbt-0005cH-00@xxxxxxxxxxxxxxxxx>
List-archive: <http://sourceforge.net/mailarchive/forum.php?forum=xen-devel>
List-help: <mailto:xen-devel-request@lists.sourceforge.net?subject=help>
List-id: List for Xen developers <xen-devel.lists.sourceforge.net>
List-post: <mailto:xen-devel@lists.sourceforge.net>
List-subscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=subscribe>
List-unsubscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=unsubscribe>
References: <E1BmFbt-0005cH-00@xxxxxxxxxxxxxxxxx>
Sender: xen-devel-admin@xxxxxxxxxxxxxxxxxxxxx
User-agent: Mozilla Thunderbird 0.7.1 (X11/20040626)
Ian Pratt wrote:

What you've configured should work just fine. Please can you try
upgrading to the latest repo as I changed some of this code
yesterday (though I don't believe there was ever a bug that would
cause this).

A couple of other things to try:
 * try configuring just one vbd i.e. no swap on hda4
 * what's the output of 'sfdisk -s /dev/hda3'
 * instead of hda3 use 0x0303

Thanks for the clear failure report; I'm sure we can get to the
bottom of this one.


# I upgraded to the latest xeno-unstable via BitKeeper wich didn't solve the problem.

# Configuring just one vbd didn't help

# Changing physdev:hda3 to physdev:0x0303 solved the problem, any idea why?

# Output from sfdisk -s /dev/hda3

I don't know if this is related, but I have had some problems with Linux/Slackware not detecting the correct BIOS geometry for my old disk. I had to add hda=16383,16,63 as a kernel parameter in my grub configuration. I tried adding the same parameter to my Xen boot entry, but without any success.

# cat /boot/grub/menu.lst
default 0
timeout 10
title=Xen 1.3
root (hd0,0)
kernel /boot/xen.gz dom0_mem=131072 com1=115200,8n1
module /boot/vmlinuz-2.4.26-xen0 root=/dev/hda1 ro hda=16383,16,63
title=Slackware 10.0
root (hd0,0)
kernel /boot/vmlinuz root=/dev/hda1 ro hda=16383,16,63


This SF.Net email is sponsored by BEA Weblogic Workshop
FREE Java Enterprise J2EE developer tools!
Get your free copy of BEA WebLogic Workshop 8.1 today.
Xen-devel mailing list