This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-cim] Python script problems, part 7 - no xen-vncfb

To: <xen-cim@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-cim] Python script problems, part 7 - no xen-vncfb
From: "Szymanski, Lukasz K" <Lukasz.Szymanski@xxxxxxxxxx>
Date: Tue, 3 Jul 2007 11:19:04 -0400
Delivery-date: Tue, 03 Jul 2007 08:16:55 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-cim-request@lists.xensource.com?subject=help>
List-id: xen-cim mailing list <xen-cim.lists.xensource.com>
List-post: <mailto:xen-cim@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-cim>, <mailto:xen-cim-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-cim>, <mailto:xen-cim-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-cim-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: Ace6rIRSzbl+x8/6R12nAIRP5idMjwC12ASA
Thread-topic: Python script problems, part 7 - no xen-vncfb

-----Original Message-----
From: Jim Fehlig 
Sent: Friday, June 29, 2007 8:21 PM
To: Szymanski, Lukasz K
Subject: Re: Got it

Szymanski, Lukasz K wrote:
> Jim -
> I finally have the script working.  The final bug was this: I did not 
> have xen-vncfb installed.  The reason for that - I did not have 
> libvncserver installed.  I think it's odd that at no point I got an 
> error that this was the case.
> Let me start from the beginning:
> I ended up putting debug statements in vnbif.py.  At the end of the 
> "vnc" if clause its supposed to execute xen-vncfb with a
> spawn_detached(arguments) call.  This failed, but there was no error 
> information in xend.log.  Do you know where it may have been?  I did 
> not see it in /var/log/messages either.  Anyway, it failed because the

> file xen-vncfb did not exist.  I found it in the xen tree, tried to 
> make it, but it needed libvncserver as a dependency.  Once I got that 
> taken care of, it needed the libvncserver and libvncclient files in 
> the /usr/lib64 directory to make it happy.
> I wonder why no one else has this problem.  Do you have libvncserver 
> installed?  xen-vncfb?  Was my not having it my fault does everyone 
> already have libvncserver installed and happy?

Yeah, didn't think to mention that.  One thing I do with bits directly
from xenbits.xensource.com is enable enable Xen API c-binding and
xen-vncfb in Config.mk.  E.g.

# Optional components
VTPM_TOOLS         ?= n
XENFB_TOOLS        ?= y
PYTHON_TOOLS       ?= y

Sorry, like I said it didn't even cross my mind but certainly necessary
when specifying 'vfb =' in vm config.  I guess there should be some
better error messages in xend so the next poor sole isn't scratching
their head :-).  Perhaps knock up a patch and send it to xen-devel.

Well glad you were able to get this solved - what a nightmare.  So I'm
headed out tomorrow.  Will check email on occasion so let me know if you
are having any other problems.  I will do some work on instance
providers using Gareth's latest interface - hopefully knock out the
remaining ones over the next few weeks.

Enjoy the 4th!

> Thanks for your help,
> Luke
> PS.  I will post the summarized version of this on the Xen-CIM list.

Xen-cim mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-cim] Python script problems, part 7 - no xen-vncfb, Szymanski, Lukasz K <=